ユーザ用ツール

サイト用ツール


よくある質問_faq

よくある質問(FAQ)

何も表示されないときは、右の 折りたたみ「閉を表示」にチェック

[Q] この FAQ は?

[A] Onshape の よくある質問と その答えをまとめたサイトです。

Onshape は、3週間ごとにバージョンアップして、ユーザーの要望を取り入れた機能強化が行われています。
このドキュメントもすぐに古くなるので、常に更新しています。困ったときは最新の公式ヘルプを参照しましょう。

[Q] Onshape とは?

[A] onshape について を 見てください。

[Q] プランとは?

[A] Onshape には、次のようなプランがあります。

  • Enterprise
  • Professional
  • Standard
  • Free

Freeプランは、いつまでも、いくつでも、モデリング機能の制限なくパブリックドキュメントを 無料で 作成/編集でき、共有もできるプランです。 プライベートドキュメントは作成/編集できません。

Standard は、個人事業者など向けの製品です。プライベートドキュメントが作成できるビジネス向けです。他のユーザーと共有、共同作業もできます。

Professinal は、中小規模の企業など向けの製品です。
複数の ID をまとめて会社(Company)として登録します。ドキュメントは、個人IDの所有とすることも、会社(Compnay)の所有とすることもでき、社外との共有の場合にも社名が表示されます。

Enterprise は、高度なデータ統制のもと迅速な仕事をするためのプレミアム製品です。
設計/購買/製造/経営、社内/外注/請負/顧客など多様な CADユーザーチームのデータを グループ化して 効率よく管理でき、ユーザーのデータアクセスの統計を提供します。

どのプランが良いかは [Q] どのプランを選べばよいの? を参照してください。

[Q] どのプランを選べばよいの?

[A] おおよそ目安を列挙します。
[Q] プランとは? も参照してください。
また、詳しくは販売店と ご相談することをお勧めします。

フリープラン が良い場合

データをすべて公開しても良いとき
公開することで 積極的に多くの人に利用してもらいたいとき
公開して人に見てもらって、意見をもらいたいとき

フリープラン では 良くない場合

公開できないデータを取り扱うとき
他の人の非公開データを編集する必要があるとき

Standard が良い場合

完全な個人事業で、共同で CAD操作をする人がいないとき
小規模な会社で、従来から1アドレスで取引先とデータをやり取りしているとき
(つまり、一人がデータ管理しているとき)

Standard では 良くない場合

1個の ID を複数のユーザーが使い回すのは問題があるとき
  * 契約違反
  * 誰が変更したか わからなくなる
  * 別の人のデータを間違えて操作してしまう
  * 同一 ID を複数人が使うと、自覚と責任が持てない
  * 社外から共有するときに責任の所在が見えない
社外と共有するときに個人のデータとして表示(社名が表示されない) 
複数の Standard があると、支払いが管理しづらい。
退社などによりデータが混乱する。

Professional が良い場合

すべての管理をする Company 所有者が1人いて、
その人がデータ全般を管理し、請求を一括できるとき

Professional では 良くない場合

複数のプロジェクトがあって、
  * プロジェクトごとに管理(担当)する人が違うとき
  * プロジェクトごとに参加するメンバーのアクセス権を管理したいとき
チームを構成するメンバーに 別々の権限を与えたいとき
例えば、閲覧だけ、編集も可能、という権限の違うメンバーでチーム共有は
できません。(Enterpriseの プロジェクト とプロジェクトロールが必要)
社外のメンバーも一括管理したいとき。

Enterprise が良い場合

部署ごとに、権限を分けて管理する組織のとき
つまり、A事業部と B事業部とで別々のデータ・人の管理をするとき
プロジェクトごとに参加メンバーを管理したいとき
プロジェクトメンバーごとに、編集可能/不可などの権限を管理するとき
(これをプロジェクトロールといいます)
外注先がライトユーザーとして利用してもらいたいとき
(つまり、リンク共有では、セキュリティの問題があると判断したとき)

CAD としての機能は、フリープランから Enterprise プランまで同じです。

違いは、データの管理方法です。

  • フリープランでは、著作権を保護できません。(パブリックドキュメントのライセンスを参照)
  • Standard では会社組織を認識できません。
  • Professional では、
    • ワンクリックでパブリック(公開)できてしまいます。
    • 共有先をチームとして登録できますが、チームメンバーに対して同じアクセス権の設定しかできません。
    • Enterprise のライトユーザーのような仕組みがないので、社外に出ていくデータの管理に関与できません。
  • Enterprise は自社ドメインの閉じられた空間でドキュメントを管理します。
    強いセキュリティを求める企業向けです。

Onshape のデータ管理方法、特に Professional と Enterprise の違いについては、Protecting Your CAD Data with Onshape(英文) に記載があります。

セキュリティ、データ管理については、詳細な情報が必要となります。販売店と相談してください。

[Q] 最新バージョンは?

[A] Onshape は、現時点で3週間毎にバージョンアップされ、常に最新版が提供されます。
何もしなくても、常に最新版を使えます。

古いバージョンは使えません。 新しいバージョンは互換性があります。FeatureScript も動きます。 既存のCAD のような バージョンの違いによるデータの互換性は問題となりません。

最新バージョンの情報は、ヘルプにある次のリンクを参照してください。

動作環境

[Q] 動作環境は?

[A] パソコン(Windows,Linux,ChromeOS) 及び Android、iPadで動作します。
インターネットが必要です。
ブラウザは、Chrome、Firefox、Safari(MacOS)、Opera、Edge です。 IEはサポート外です。

詳しくは
ハードウェアおよびグラフィックパフォーマンスの推奨事項
ハードウェア環境(サインイン必要)

動作環境の確認ができます。

[Q] ユーザー登録して最初にすることは?

[A] 日本語で使う設定をしましょう。日本語の設定
最初に知っておきたいこと

[Q] 日本語が表示されない?

[A] ユーザーの使うほとんどの箇所で 日本語が使えるようになっていますので、次の確認をしてください。

  • サインインしていない(リンク共有)場合、アカウントを取得してください。
  • サインインして メニューなどを日本語表示するための設定が必要です。(FreeプランでもOK)
    My account (マイアカウント)で Preferences(設定)をクリックし、Language(言語)を「日本語」に設定してください。Save language(言語を保存)をクリックすると、いったんログアウトして、再度ログイン以後 日本語となります。日本語の設定
  • ヘルプが日本語表示されない場合、クラウド接続で一時的に日本語返還が読み込まれていない場合がありますので、 ブラウザの再読込(f5キー)をクリックして読み込み直してください。再読込を繰り返しても日本語表示されない場合、和訳がまだされていない可能性があります。(3週間ごとにバージョンアップしますので、ヘルプが更新されてから和訳が間に合っていない場合もあります)
    [Q] 日本語表示が おかしい?
  • 図面(Drawing)タブの注釈などで 日本語が「文字化け」まはた「表示されない」場合、注釈を編集して日本語フォントNoto Sansa Japaneseに設定をしてください。
  • 図面全体で日本語を使いたい場合(多くの場合がそうですね)、日本語に設定したテンプレートを使うのが良いです。デフォルトテンプレートは日本語未対応のフォントが使われている場合があります。
[Q] 日本語表示が おかしい?

ブラウザ Chrome などには、英語を自動的に日本語に翻訳する機能があります。
この機能が 動作しているとき、日本語が正しく表示されない場合があります。

Chrome などの 自動翻訳をオフにしてください。日本語の設定

[Q] ミリ、インチなどの単位は?

[A] 単位は自由に選ぶことが出来ます。

  • ワークスペースの単位を確認してください。この単位がデフォルトで使われます。


  • スケッチの寸法入力などの数値フィールド入力欄は、数値だけならデフォルト単位となります。mm,millimeter,cm,m,meter, in,inch, deg, radian などの単位が使えます。
  • 入力欄は、関数が使えます。pi(PI,Pi)は円周率です。
  • PartStudio ではローカル変数が使えます。変数は、単位付きと 単位なし のどちらか選択できます。例えば 変数 a が単位なしのとき sin(#a) は デフォルトの単位が補われます。#b/mm*radian のように単位の演算もできます。
  • 図面タブでは、図面のプロパティに デフォルト単位の設定があります。個々の寸法でも設定できます。インチと mm の両方併記もあります。

画面について

[Q] ドキュメントページとは?

[A] サインインしたときに最初に表示されるページで、ドキュメントの一覧が表示されます。
(英語では Documents Page です。複数のドキュメントを表示するページです)  他のページからは、左上 Onshape ロゴをクリックして移動できます。

ドキュメントページ

他のページからは をクリックすると、ドキュメントページに戻れます。\\

[Q] ダークモード(背景黒)は?

[A] 要望が出されていますが、現在は ブラウザのアドオン(Dark Reader など)を使うのが良いでしょう。

ブラウザのアドオンは自己責任でお願いします

共有

[Q] 共有とは?

所有者以外の人が ドキュメントの操作/閲覧ができるようにする設定を 共有と言います。

どの<共有種類>を使うと、誰が(Who) サインイン 要/不要 で <何ができるか> を表にしました。
  (◯:デフォルト。 ✔:共有ダイアログのチェックで制御可能)

<共有種類> Who サイン
イン
閲覧編集コピーリンク
(挿入)
エクス
ポート
(再)
共有
コメ
ント
削除
パブリック
共有 *1
誰でも
リンク
共有
リンク(URL)を
知る人が
不要 ◯*2
個人共有
(表示可能)
指定 IDで 要 ◯✔ ✔*4 ✔*5 ◯✔
*3
個人共有
(編集可能)
指定 IDで 要 ◯✔ ◯*3 ◯✔*4 ✔*5 ◯✔ ◯✔
*3
✔*6

<何ができるか>の詳細は次のとおり。

<何ができるか> 具体的にできること
閲覧 ビューの回転、シェードなど表示制御、長さ,角度などの測定、質量属性の表示など。
編集 共有ドキュメントの直接編集。(ただしコメントの記入は除く) *3
コピー ドキュメント(ワークスペース)をコピーして 自分のドキュメントを作ること。*4
リンク(挿入)
ドキュメントを
リンクする
共有するドキュメントのパーツなどを 別のドキュメントに挿入すること。 *5
コメント ドキュメントのコメント(左側の 吹き出しアイコン) を作成すること。*3
エクスポート 各種フォーマットでエクスポート(ダウンロードすること)
(再)共有 他のユーザーとドキュメントを再度共有
削除 ドキュメントをゴミ箱に移動*6。 または、ワークスペースを削除。

*1 Enterprise所有のドキュメントは、パブリック共有は設定できません。
*2 リンク共有の場合、履歴 バージョンの閲覧はできません。
*3 共有を設定しても フリープランの人は プライベートドキュメントを編集/コメントできません。
*4 フリープランのとき、パブリックドキュメントとしてコピーすることになり、注意が必要です。 コピーは、ワークスペースのコピー、バージョンのコピーが可能です。
*5 リンク(挿入)するとき バージョンがなければ作成することが必要です。編集可能でなければ、編集可能な所有者などにバージョン作成を依頼する必要があります。
リンク(挿入)とは、PartStudioタブへの派生(drivered)、アセンブリ/図面タブへの挿入(insert)、FeatureScriptタブへのインポート(import)です。
*6 ドキュメントを削除すると 所有者/作成者のゴミ箱に移動し、共有は無効となります。ゴミ箱から復元するのは 所有者/作成者しかできません。

上記以外に、プランや 条件によって使える共有があります。

上記以外の
<共有種類>
プラン 共有先 設定項目など
チーム共有 すべてのプランチームメンバー個人共有と同じ
Company共有 ProfessionalCompanyメンバー個人共有と同じ
ゲストを招待(Invite guests) Enterprise ゲストID ここを参照
アプリと共有 外部アプリを利用外部アプリアプリによる

リンク共有は、誰が見るのか把握できないことに注意してください。
リンク共有は、リンクURL を教えた人が 別の人に伝えた場合も見ることができます。
ローカルファイルをメール添付して送信する場合、データ流出に注意を払う人も、ウェブページのURLを うっかり人に伝えたり、公開してしまう危険があることを注意すべきです。

プライベートドキュメントを フリープランの人と共有するときは表示可能が推奨です。
編集可能な共有であっても、フリープランではプライベートドキュメントを編集できません。
また、リンク(挿入)、コピーを可能な共有のとき、フリープランはパブリックドキュメントで扱います。
(事実上 プライベートをパブリックに変換したことになります。)
プライベートドキュメントを共有していた人が、フリープランに変更する場合も注意が必要です。
フリープランでは、プライベートドキュメントの閲覧だけが可能です。

個人共有は、共有設定ダイアログで 共有したい個人の ID(メールアドレス)を指定します。
共有を安全におこない場合は、チーム共有や Company共有 の採用を検討してください。チーム共有や Company共有では、 毎回メールアドレスを入力するのでなく、登録済みの 複数(あるいは1個)のIDと チーム名や Company名で 共有する ことができて便利です。

共有の設定は、所有者 または 管理者が行います。

できる限り正確な記述を心がけていますが、
不明な点があれば公式ヘルプを参照の上、誤記があれば ご連絡ください。
[Q] リンク共有とは?

[A] Onshapeの ID を持っていない人でも データ(ドキュメント)を見てもらえる方法です。
ダウンロードはリンク先を参照してください。

ビュアーを用意したりソフトウェアをインストールすることなく、最新のデータを確認することができます。

リンク共有を設定した Onshapeのドキュメントは、サインインしなくても ウェブページのアドレス(URL)をブラウザに入れるだけで 閲覧できます。
ドキュメントの権限のある人から URLを教えてもらってください。通常は、https://cad.onshape.com/documents/... の形です。

URL を知っている人は誰でもアクセスできます。URLを他の人に教えるときは、データの所有者に確認を取るなどデータ管理に注意してください。

ブラウザでリンク共有のURLを開くと次のように表示されます。


View Tools cubebox をクリックしてビューオプションを表示できます。

編集はできません。ID取得して 他の共有設定が必要です。

英語表記です。日本語にするには ID を取得 サインインし、日本語の設定が必要です。
日本語のヘルプは ここ(閲覧限定ツールバー)にあります。

Enterpriseのドキュメントは、(セキュリティの理由から)リンク共有ができないようになっています。ライトユーザーとして登録してもらってください。

[Q] リンク共有でダウンロードはできますか?

[A] リンク共有は、サインイン無しで エクスポート(ダウンロード)可能にする設定があります。
エクスポート可能にするかどうかは、権限のある人が設定します。

エクスポート可能になると、3次元データ(.igs, .x_b, .stl など)、2次元データ(.dxf, .pdf など)をダウンロードできるようになります。

また、エクスポート可能でない場合でも、Part Studio と アセンブリはブラウザでプリンタ出力できます。
図面は、直接プリンタ出力できませんが、pdf に変換されたタブがあれば ダウンロード、プリントアウトが可能です。

[Q] どの共有を使えば良いのですか?

[A] 取引先(納入、仕入、外注などの社外の方)とデータを共有する場合を まとめました。
2個以上の共有を組み合わせて使うことも可能です。

取引先が ID を持っていない場合
リンク共有が可能です。
相手先で 共有の URL を 管理できることが必要です。リンク共有の詳細はこちら
必要ならば、エクスポート可能な設定をするか、必要な形式のタブを用意してダウンロードしてもらうこともできます。

取引先が Enterpriseのライト(あるいはフル)ユーザーである場合
プロジェクトを利用して共有可能です。
費用はかかりますが、一番安全な方法です。
取引先が Standard または Professional の ID を持っている場合
相手のメールアドレスを聞いて、個人共有をします。
あるいは、何度も共有する相手であれば、
マイアカウント(MyAccount)> チーム(Team) でチームを作成して
チーム共有をします。
編集/表示可能、コピー、エクスポートなど適切な設定ができます。
取引先が フリープランの ID を持っている場合
前項目と同様に、個人共有 または チーム共有をします。
ただし、「編集可能」でなく 「表示可能」 とすべきです。
さらに、コピー、リンクは チェックを外す べきです。

これらは設定してもフリープランでは使えません。間違ってコピーするとパブリックドキュメントとなり公開されます。
メールで情報交換する場合は、コメントのチェックも不要です。

エクスポートをチェックすると、全タブで全形式のダウンロードが可能となります。
エクスポートのチェックがなくても、リンク共有でエウクスポートの設定すれば、用意されたタブだけのダウンロードが可能です。
[Q] チームとは?

1個以上の ID をチームとして登録しておくことで、チームで一括して共有の設定ができるようになります。

ドキュメントページの右上 をクリックして、マイアカウント または Company設定 または Enterprise設定チームから 設定できます。(Company があるプランの場合、Company と 個人アカウントのどちらでも設定できます)

チームには、管理者(すくなくとも1人) と ユーザー(0人以上)がいます。
管理者は、メンバーの追加/削除/役割(管理者かユーザーか)変更、チーム共有の削除、チームの削除ができます。

チームが作成されると、ドキュメントページの右側にチームが表示されますので、ドキュメントが探しやすくなります。

[Q] Companyとは?

Professional または Enterprise のプランで 1個以上のIDの請求をまとめる単位です。

Professional の場合、所有者 と 管理者 と 他のユーザーがいて、メンバーの請求は一括されます。
Enterprise の場合、その他に フルユーザー、ライトユーザーなどの種類があります。 Company は、会社名などの情報の登録の他 メンバーが共通して使える設定があります。

個人共有と同様に、同じ Companyでの ID で共有する設定ができます。 メンバーでない(請求を一括しない)ユーザーと共有する場合は、チーム共有を検討してください。

入出力

[Q] エクスポートは どのようにするのですか?

[A] ダウンロードしたい「物」で右ボタンクリックすると 各種フォーマットで それぞれのデータが出力できます。

[Q] 3Dプリンタへの出力は?

[A] ほとんどの 3Dプリンタは STL形式のファイルを取り扱います。Onshape は パーツ または サーフェスを STL形式でエクスポートすることができます。

次のどちらかの方法で STLフォーマットで エクスポートします。

  • タブボタン(画面下 PartStudio1 などと表示)を右クリックメニュー
  • パーツまたはサーフェス(左側下部パートリストの中の必要なボディ)を右クリックメニュー

STL は、バイナリ と テキストの2形式があり、一般にバイナリの方がファイルサイズが小さくなります。

STL ファイルは、単位の情報が含まれていません。インポート、エクスポートのときに単位を指定する必要があります。

オプションで タブに保存すると、エクスポートされたデータのタブが作成されます。

ドキュメント

[Q] ドキュメントとは?

[A] Onshape にはファイルがありません。
代わりに ドキュメントという単位で クラウドに保存します。

ドキュメントは、Windows のファイルより強力です。
複数のタブを取り込めることなどは、むしろフォルダに近いものです。 ドキュメントとは

Onshape物語参照

[Q] ドキュメントの検索は?

[A] ドキュメントページの一番上に検索欄があります。

その欄の右側にある ▼ をクリックすると、いろいろな検索方法があります。
高度なドキュメント検索

[Q] パブリックドキュメントとは?

[A] 誰でもが閲覧でき 自由にコピーできるパブリック共有を設定したドキュメントです。
ドキュメントページから 世界中のパブリックドキュメントを探せます。

パブリックドキュメントは、誰でもが(技術的に)コピー可能です。
著作権について記載がなければ、著作権がないものと推測されます。(詳しくは[Q] パブリックドキュメントのライセンスは?を参照。

フリープランのアカウントは、パブリックドキュメントだけを作成/編集できます。
機密を含むデータを作成/アップロードするときは、プライベートドキュメントを作成できるアカウントを取得しましょう。

[Q] パブリックドキュメントのライセンスは?

[A] パブリックドキュメントは、技術的には誰でもコピー/再配布ができますが、
ライセンスを記載したタブを付けることで、他者に著作権保護を求めることができます。
(ただしフリープランを除く)

一般的な 公開されたウェブページは、技術的にコピー可能であっても 著作権保護されていて 無断コピーはできないとされています。
パブリックドキュメントは、LICENSEタブを付けるときだけ 同様の著作権保護ができます。

ドキュメント作成日 所有者のプラン ライセンスの記載 適用されるライセンス
2018年8月7日
より前
どのプランでも 記載タブあり 記載のライセンス
なし 権利保護なし
2018年8月7日
以後
フリープラン 有無に拘らず 権利保護なし
フリー以外 記載タブあり 記載のライセンス
なし 権利保護なし
正確な記述は
原文参照
(前略) If you choose to publish a Public Document or (中略)
For any Public Document owned by a Free Plan User created on or after August 7, 2018, or any Public Document created prior to that date without a LICENSE tab,(中略)
For any Public Document created prior to August 7, 2018 and for any Public Document owned by any Onshape user who is not a Free Plan User, created on any date which contained a tab called LICENSE reserving rights greater than the foregoing,(中略)
Onshape shall have no liability for any damages resulting from the use or misuse by any third party of Customer’s published Public Document or your postings.(後略)
参考和訳(前略)パブリックドキュメントを公開するとき(中略)フリープランが所有する2018年8月7日以後に作成されたパブリックドキュメント、またはその日より前に作成された[ライセンス]タブのないパブリックドキュメントの場合、(中略)
2018年8月7日より前に作成されたパブリックドキュメントと、フリープランではないユーザーが所有するドキュメントは、権利保護のLICENSEというタブが含まれていれば作成日はいつであっても、(中略)
Onshapeは、お客様が公開した公開文書またはお客様の投稿の第三者による使用または誤用に起因するいかなる損害についても責任を負わないものとします。(後略)

権利保護なし の場合は、他の人が使用/コピー/変更/配布/販売などを制限なくすることができます。

Onshape の FeatureScriptドキュメントから閲覧利用できる std には MITライセンス(商用利用可能)の LICENSEタブがあります。

その他に 「記載のライセンス」には、例えば クリエイティブ・コモンズ・ライセンスのようなものが考えられます。
この場合であっても、技術的にコピーは制限されませんし、Onshape は保証しません。 技術的にコピーができないようにするには、プライベートドキュメントを利用しましょう。

フリープランでは、著作権等のタブを付けても無効です。

[Q] フリープランに移行すると、プライベートドキュメントは?

[A] Professional、Enterprise などのプランから フリープランに移行すると、プライベートドキュメントはプライベートドキュメントのまま保持されます。
ただし、フリープランではこれらを編集することはできなくなります。

プライベートドキュメントを パブリックに変更すると編集可能となりますが、公開されます。

プライベートドキュメントのまま保存してあれば、Professinalプランなどに復帰するとき、プライベートドキュメントとして編集可能となります。

以上は、実際の動作の話ですが、Onshape の規約は 次のようになっています。

正確な記述は
原文参照
(前略) and we also have the right but not the obligation to maintain Content that Customer or any End User has not permanently deleted prior to Customer’s cancellation. (後略)
参考和訳(前略)また、(Onshapeは)お客様またはエンドユーザーがお客様の(サブスクリプションの)キャンセル前に完全に削除していないコンテンツを維持する権利はありますが、義務はありません。 (後略)
[Q] ワークスペースとは?

[A] ワークスペースとは、文字通り作業をする場所です。

最初にドキュメントが作られると、PartStudio と アセンブリのタブが作られますが、この2個のタブを含むのがワークスペースです。

ワークスペースでは、フィーチャーを作成、タブを追加などの作業ができます。
作業をするたびに、その直前のワークスペースの状態のコピーが履歴として順に積み重ねられていきます。履歴の図の枝は、この履歴の積み重ねを表現していて、枝の一番上に ◯があるのがワークスペースを表示しています。

ワークスペースは、作業をする場所ですが、履歴の上では直接作業できません。(つまり、履歴は 名前やプロパティを除いて変更ができず、過去の記録としてしか使えません。)
変更したい場合は、バージョン にしてから ブランチ を実行してワークスペースを増設する必要があります。

ドキュメントページからドキュメントを選択してワークスペースのコピーを実行すると、ワークスペースのコピーを入れた新しいドキュメントを作ります。

共有がある場合、他人が所有するドキュメントのバージョンから ワークスペースのコピーを作り、自分のドキュメントを新しく作ることができます。

[Q] タブとは?

[A] ワークスペースは、複数のタブがあります。(ブラウザのタブとは全く別物です)

ドキュメントを新規作成したときの最初のワークスペースには、PartStudio と アセンブリの2個のタブがあります。

タブには次の種類があります。

  • PartStudio 主に スケッチや パーツ、サーフェスを作成するタブ
  • アセンブリ PartStudio で作成したパーツなどや 他のアセンブリ(サブアセンブリと言います)を挿入(リンク)して 組み立てるタブ
  • 図面 PartStuidoや アセンブリを挿入(リンク)して 紙図面を想定した図を描くタブ
  • その他


ドキュメントの編集画面の左下 + アイコンからタブを挿入でき、ここから インポートを実行することもできます。
インポートがサポートされているファイルタイプの場合、変換されてさらにタブが追加される場合があります。
サポートされていないファイルタイプの場合、そのデータのタブが1個つくられて、ダウンロードができ、クラウドドライブにファイルを保存するように使えます。

右下 + のアイコンのさらに左側のアイコンをクリックすると、タブマネージャーが開きます。タブをドラッグして順序を入れ替えたり、フォルダ(多階層可)を使ってまとめることも可能です。

[Q] 履歴とは?

ワークスペースが変更されたときに、直前の状態を保存したものです。

ドキュメントの 編集画面右上のアイコンをクリックして 枝の図を表示できます。「変更を表示」をクリックして、履歴の全部を表示できます。
[Q] ワークスペースとは?[Q] バージョンとは?を参照。

[Q] バージョンとは?

[A] バージョンは、履歴 または ワークスペースに、名前や説明(Description)を付けたものです。

履歴をバージョンとすることで、次のことができるようになります。

  • 履歴の枝の図を表示するときに バージョンとして目立つ表示になる
  • 名前を付け、説明(Description)を付けられる
  • ブランチ を作成できる
  • 共有 先からリンク(挿入)できる
  • ワークスペースにマージできる
  • ワークスペースを削除したときに、残すことができる
[Q]ブランチとは?

[A] バージョン をコピーして新しいワークスペースを作ることです。

これにより 1個のドキュメントに、複数のワークスペースが存在し、履歴の枝の図で 複数のそれらが ◯ が表示されます。
◯ をダブルクリックして 編集するワークスペースを選択できます。

ワークスペースは、それぞれが履歴のリストを持ちます。履歴の枝の図で枝分かれで表示されているのがそれです。

ワークスペースは、(リンクがない限り)お互いの影響はなく、独立して編集できます。 ブランチを繰り返すことで、1個のドキュメントに ワーススペースはいくつでも増やせます。
Onshape物語参照

[Q]ブランチの操作?

[A] ブランチ することで、ワークスペースが複数でき、それぞれが履歴の枝を持つようになります。

ブランチ前と同様に、履歴は名前を変えたり 説明を変更する以外には変更できません。

しかし、ワークスペースについては次の操作ができます。

  • Mainでない(最初からある枝の先端でない)ワークスペースは削除できます。
    削除すると直前のバージョンからの履歴(変更を表示をクリックして表示される履歴)も削除されますので、必要ならば最新のバージョンを作成してから削除してください。
  • ワークスペースを削除した枝の先端は ◯から ●に表示が変わり、以後編集ができなくなります。しかし、● で 「ブランチワークスペースの作成」を実行して再び編集ができるようにできます。
  • ワークスペースは、自身以外の履歴をマージすることができます。マージ参照
[Q] 所有者とは?

すべてのドキュメント と フォルダは、ID を持つユーザー または Company が 所有者となります。
これらが新規作成されるとき、<誰が>作成するかによって<デフォルトの所有者>が決まります。

<誰が>作成するとき <デフォルトの所有者>
Company所属のユーザー
(Professional または Enterprise プラン)
Company
(複数に所属するときは選択可)
Company所属しないユーザー
(Free,Education,Standardプラン)
作成者(個人)

所有者は、管理者の権限(ドキュメントの削除、共有権限設定/変更)に加えて、所有権の譲渡 などの権限を持っっています。

所有者は変更することができます。(作成者は変更できません)

Professional以上のプランでは Company があります。
Company はドキュメントの所有者となることができます。

Company の関係する 所有者変更をするときは、ドキュメントのメタデータが影響することに注意してください。
詳細は 所有権を転送するを参照

Company の請求を一括して受けるなどの ID を Company の所有者と呼びますが、ここで説明する ドキュメント(またはフォルダ)の所有者とは別のものです。

[Q]ドキュメント/ワークスペース/バージョン/タブの関係?

[A] 少し細かい説明ですが、次のとおりです。

ドキュメントは、ID を持つデータ単位です。
ドキュメントが新規作成されるとき、IDが割り当てられ、ゴミ箱で消去されるまで変更されません。 (所有者が変更されたり、名称が変更されても IDは不変)
IDは url で、ブラウザからアクセスしたり、リンク(挿入)するときに ID で検索できます。

ドキュメントは次から構成されます。

  • 1個以上のワークスペース
  • 0個以上の履歴(version Start を含めれば1個以上)
  • 所有者/共有権限 などの情報
  • ドキュメントの名前、ドキュメントプロパティ(説明) などの情報

ワークスペースは次から構成されます。

  • 1個以上のタブ

タブは、次のいずれかです。

  • PartStudio
  • アセンブリ
  • 図面
  • FeatureScript
  • その他

履歴はワークスペースのコピーです。 履歴は、ワークスペースごとにツリーを構成し、ワークスペースを変更すると1個ずつ作られます。

バージョンは、履歴に 名前とプロパティを付加したものです。

履歴とバージョンは一度作成されると削除できません。(例外は、後述のワークスペース削除のとき)

ワークスペースのコピーであるバージョンから、 ワークスペースを作成(復元)することができます。(これをブランチと言います)
ドキュメントのワークスペースは、1個増えて、履歴ツリーも作られます。

ワークスペースが複数あるとき、Main 以外のワークスペースは削除することができます。
このとき そのワークスペースのバージョン(と バージョン間の履歴 とその履歴ツリー)は残りますが、最後のバージョンからワークスペースまでの履歴は削除されます。
残されたバージョンをコピー(ブランチ)してワークスペースを作成することもできます。

ワークスペース または バージョンをコピーして新規ドキュメントを作成できます。
これにより、実質的に履歴やバージョンを削除することができます。(ただし IDや共有属性などのワークスペース以外の情報はコピーされません)

タブは 次のコマンドで別のタブのリンク(挿入)を作ることができます。

  • PartStudioタブの派生(drivered)
  • アセンブリ/図面タブの挿入(insert)
  • FeatureScriptタブのインポート(import)

挿入元のタブは、次のどちらかです。

  • 同じワークスペースの他のタブから
  • 別のドキュメント または 同じドキュメント のバージョンのタブから

ワークスペースのリンク(挿入)を作るとき、リンク元が変更されると即時に反映されます。 PartStudio では メニューの「このワークスペースのカスタムフィーチャー」を使います。

バージョンのリンク(挿入)は、デフォルトでは最新バージョンが挿入されます。 バージョンが作成されていないとリンクできません。 PartStudio では メニューの「カスタムフィーチャーを追加する」でフィーチャーをメニューに登録してから挿入します。

リンク後に リンク元のバージョンが更新するなど 最新版でないバージョンのリンクは、 フィーチャーリストに が付けられて表示されます。

他のドキュメントのバージョンをリンク(挿入)するときには、「ドキュメントをリンクする」共有権限が必要です。

キーボード・ショートカット, ツールバー

[Q] キーボードショートカットを教えて

[A] 画面右上の からキーボードショートカットをクリックして表示するか、または キーボード '?' を押して一覧が表示できます。
キーボードショートカット に登録されているコマンドは、とても便利で よく使うコマンドです。キーから操作しない場合でも覚えておいたほうが良いでしょう。

's'キーは、ショートカットツールバーが表示されて、便利です。

[Q] キーボードショートカットのカスタマイズは?

[A] できません。
ショートカットツールバー 及び ツールバー(メニュー)のカスタマイズは可能。

[Q] キーボードショートカットの制限

[A] ブラウザ,環境によって使えないキーがあります。(パソコン Chrome が一番制約が少ないようです)

[Q] ツールバーのカスタマイズできますか?

[A] PartStudio の ツールバーで右ボタンクリック「ツールバーのカスタマイズ」ができます。

選択

[Q] クリックすると 追加されるのですか?

[A] グラフィック画面で 図形要素をクリックすると、既存の選択に追加選択となります。他の多くの CAD では既存の選択が解除されて、クリックされた要素だけが選択となるのとは、異なります。
単一要素を選択したい場合は、スペースキー(選択解除)を押すか、何もないところをクリックするか、既存選択要素をクリック(トグルで選択解除)してから、必要な要素をクリックしてください。
選択

[Q] 選択作成とは?

複数の要素を効率よく選択するための機能です。選択作成(Create Selection)

[Q] クリックで選択できないときは?

フィーチャーの作成/編集のとき 編集ダイアログが開き、図形要素を選択することができます。 例えば、押し出しフィーチャーでは、グラフィック画面でスケッチをクリックすると「押し出しするフェースとスケッチ領域」という入力フィールドに入力されます。 これがうまく動作しないとき、次をチェックしてください。

  • 入力フィールドがフォーカス(色が付いている)状態であるか
  • グラフィック画面で 適切な図形要素をクリックしているかどうか
    押し出しの場合、ソリッドと サーフェスではクリックできる図形要素が違います
  • クリックできる図形要素は表示されているものだけです。仮表示の状態は選択できません。

図形要素のクリックで苦労する場合は、

  • パーツ、フィーチャー(スケッチ含む)を選択する場合、左側のフィーチャーリスト、パーツリストからも選択できます。
  • 右ボタンメニューから「他を選択」を使うと、複数の候補から希望の選択ができます。
    (キー ` ただし日本語キーボードでは不可。) (SolidWorks の「順次選択」に相当)
  • 右ボタンメニューから「選択作成」を使うと、複数の図形要素を効率よく選択できます。

PartStudio

[Q] PartStudio で何ができますか?

[A] 次のような図形要素を作ることができます。

  • ソリッドボディ(パーツ) : 体積をもつ立体です。
  • サーフェスボディ : 厚みのない立体です。
  • カーブ : 3次元空間の線(直線、円弧、曲線などから構成)
  • スケッチ : 特定の平面上の2次元図形です。
  • 複合部品 : 複数のボディを1個として扱えます。
  • その他 : 点、合致コネクタ、平面など

1個の PartStudio に 複数の図形要素を含めることができます。
座標、面積、体積、重心、モーメントなどを計算できます。
シェーディング、ストライプ表示、など形状の確認ができます。
アセンブリや 図面で挿入して利用できます。
他のPartStudio へ派生したり、他のPartStuido から派生したりして利用できます。
3Dプリンタや 他のCADで取り込めるような形式でエクスポートできます。

フィーチャー(全般)

[Q] 実行結果が表示されない?

[A] フィーチャーを編集中(ダイアログが開いている間)に実行結果が表示されているのに ☑ をクリックした途端に表示が消える場合は、実行結果の表示/非表示を確認してください。

「パーツを削除」フィーチャーは、削除されて表示がなくなります。 「面を削除」「ブール演算」の交差、「押し出し」の削除で全部削除、など実行結果として、パーツなどがなくなるフィーチャーがあります。

Onshape は「ブール演算」で結合/削除/交差する部分がない場合、
「押し出し」の追加/削除/交差する部分がない場合、
フィチャーはエラーになりません。(メッセージ出力がある場合があります)

[Q] フィーチャーとは?(簡単な説明)

[A] PartStudio の左側に表示される フィーチャーリストに列挙されるものです。 フィーチャーリストの順に実行されて、目的の形状を作ることができます。

スケッチもフィーチャーリストに列挙されるフィーチャーですが、スケッチ編集で作る 有限直線、円、寸法などはフィーチャーでありません。
名前付きビュー、パーツに割り当てられる材質などもフィーチャーでありません。

フィーチャーには、最初から組み込まれている標準フィーチャー(Standard feature) と ユーザーが追加することのできるカスタムフィーチャーがあります。カスタムフィーチャーは FeatureScript を使って自由に作ることができます。

フィーチャーは、画面上のツールバーのアイコンをクリックして実行できます。(ショートカットツールバー、ショートカットキーなどからも実行できます)
カスタムフィーチャーは、 をクリックしてツールバーに追加することができます。

[Q] フィーチャーで何ができますか?

[A] フィーチャーは、PartStudio の中で パーツなどを作成したり、変更したり、削除したりします。

作成したパーツ、複合部品、サーフェース、曲線は、左側フィーチャーリストの下に表示され、をクリックして表示/非表示ができます。

スケッチ、複合曲線などは、フィーチャーリストのフィーチャーにある で表示/非表示ができます。

変数フィーチャーは、変数を作成/変更します。変数は画面に表示されず、右側の変数テーブルに表示されます。

[Q] フィーチャーとは?(詳しい説明)

[A] FeatureScript では、フィーチャー関数(feature function)という「関数」を定義できます。
フィーチャー関数は、context と definition を引数に取ります。

context は PartStudio の中身であって、次のようなものを含んでいます。
・ ソリッド, サーフェス, スケッチ, 曲線などの有限の大きさを持つ図形エンティティ
・ 点,平面 などの大きさのない幾何図形 (SolidWorks で参照ジオメトリと呼ぶもの)
・ 変数

definition は 長さ/角度などの数値、 contextに含まれる図形、 他のタブや他のドキュメントへの参照などのパラメータで、フィーチャーを作成/編集するときに開かれる フィーチャー編集ダイアログに表示されるものです。
例えば、押し出しの場合
・ ソリッド/サーフェスの2者択一
・ 新規/追加する/削除する/公差 の選択
・ ブラインド などの末端の選択
・ 奥行きなどの長さ
・ その他のパラメータ
などを設定します。

フィーチャーリストに並べられるのは、フィーチャー関数のインスタンスです。
つまり、フィーチャーリストは、押し出しなどの関数を ユーザーが指示するパラメータ(definition)で実行して context に影響を与える、順序を持った一連の動作指示です。

[Q] フィーチャーと パーツの名前は変更できますか?

[A] フィーチャーリストの変更したいフィーチャーの右クリックメニューから、または パーツリストの変更したいパーツの右クリックメニューから 名前の変更ができます。
ショートカットキーは Shift+n です。

フィチャーは、最初に作成するときに フィーチャー名 + 番号の名前が付けられます。
フィーチャーリストの順序が変わっても名前は変更されません。

パーツは、デフォルトで 'Part' + 再構築時の番号 が付けられます。
フィーチャーの変更などで生成されるパーツの個数が変われば、デフォルトの名前は変わります。
shift+n で 別名を付ければ、それは変わらなくなります。

これらは、同じ名前を使うこともできます。

[Q] フィーチャーの検索は?

[A] フィーチャーリスト(画面左側)の一番上に検索を入力する欄があります。

マウスをその場所で しばらく留めておくとヘルプメッセージが2回に渡って表示されますので、それを見てください。

例えば、:part 部品1 と入力すると パーツ “部品1”を作るのに使ったフィーチャーだけが表示されます。

[Q] (イン)コンテキスト モデリングとは?

[A] アセンブリの状態(これをコンテキストという)を表示/参照しながら、PartStudio でモデリングすることです。

アセンブリに組み付けた後で、構成部品を編集(変更)したい場合があります。
(これをトップダウン設計と言います。)
これを実現するために コンテキスト モデリング(in-context modeling, インコンテキスト モデリング)を使います。

  1. アセンブリタブで 挿入済みのパーツなどの上で 右ボタンメニューから「コンテキストで編集」をクリックすると、パーツが定義されている PartStudio に移動し、
    コンテキスト モデリングが開始されます。

  2. コンテキスト モデリングが開始されると、
    アセンブリに表示されていたものが PartStudio にも ゴースト表示(透明表示)され、
    画面上方に 透明度スライドバーと アセンブリに戻るボタンが表示されます。
    さらに、左側フィーチャーリストの上に、プルダウンメニュー(アセンブリ コンテキスト)が表示され、後述する コンテキスト オブジェクトを選択できるようになります。

  3. ゴースト表示を 参照してモデリングができます。 例えば、スケッチ平面として使うことができます。

  4. ゴースト表示は、この PartStudio の中では変更できません。
    この PartStudioの外部で作られた アセンブリを構成する部品だからです。

  5. ゴースト表示は、コンテキスト モデリングを開始した時点でのアセンブリのスナップショット(瞬間のコピー)です。
    つまり、コンテキスト モデリングを開始した後で、アセンブリを変更しても、ゴースト表示に反映されません。(後述の更新をしない限り)

  6. コンテキスト モデリングの最中に ゴーストを参照するモデリングを行うと、ゴースト表示はコンテキスト オブジェクトとして PartStudio に保存されます。

  7. コンテキスト モデリングの最中に ゴースト表示を参照するモデリングをせずに アセンブリに戻る(PartStudioを離れる)と、ゴースト表示は保存されずに 消去されます。

  8. 複数の コンテキスト オブジェクトを PartStudio に保存することができます。
    つまり、コンテキスト オブジェクトを作成した後で、再び アセンブリで 新しい コンテキスト モデリングを開始すると、その時点の違うスナップショットが作られ、参照してモデリングをするときに 新しい コンテキスト オブジェクトが作られます。

  9. 左上のメニューから 複数のコンテキスト オブジェクトから使用ものを選択できます。
    コンテキスト オブジェクトが不要ならば、削除できます。
    コンテキスト オブジェクトは更新することができ、古いスナップショットは 更新時点でのスナップショットに置き換えられます。

  10. フィーチャーは、コンテキスト オブジェクト への リンクを示すマークが付きます。

押し出し

[Q] 押し出しは、閉じたスケッチから作るのですか?

[A] スケッチがなくても ソリッドを作れる場合があります。 ソリッドの押し出しは、次のどちらか(あるいは両方)から作ります。

  • 面(ソリッド/サーフェスを構成する平面) (下図の⑥)
  • 領域。スケッチ要素と スケッチ平面を構成するエッジ で閉じた領域。(下図の①〜⑤)


サーフェスの押し出しは、スケッチ要素から作ります。

平面,サーフェス

[Q] 垂直な平面を作るには?

[A] フィーチャー「平面」で、線角度 を選択、角度を 90度に設定
スケッチなどで平面を使おうとしているなら [Q] 平面を使わないでスケッチを作る方法は?

[Q] サーフェストリムは?

[A] 分割コマンドを使います。「両側面を保持する」のチェックを外します。
互いにトリムして結果としてソリッドを作る場合は、「囲い込み」を使うことができます。

両サーフェスのトリムはMutual Trim を使うことができます。

[Q] スケッチなどから 平面サーフェスを作るには?

[A] スケッチ領域がある場合は オフセットサーフェスを使います。
(フィル フィーチャーも使えます)

面(face), GAP(穴)

[Q] アンダーカットの部分は?

[A] グラフィック画面ののプルダウンメニューから「抜き勾配分析」をクリックして アンダーカットの色を変えて表示できます。

アンダーカットの部分を分離するには、Split by Isocline FeatureScript が使えます。

[Q] フィルパターンや スケッチパターン はありますか?

[A] パターンに いろいろなパターンがあります。

フィルパターン
点パターン
カーブパターン
変数を使ったパターン 変数で位置/大きさ/その他を変化させながらパターン
トランスフォームパターン 点 または 合致コネクタに移動/回転して 新規/結合/削除/交差
面パターン

アトラクタパターン Attractorsに近くを大きく、遠くを小さく配置。同じ大きさも可能。多彩な配置(疑似乱数など)が可能。

合致コネクタ

[Q] 合致コネクタとは?

[A] 合致コネクタ(Mate connector)は、言葉の通り合致(2個の図形要素の位置関係を拘束すること)させて ソリッドを接続するのに使いますが、実際にはもっと広い使い方ができます。

合致コネクタの 実体は 座標系です。つまり、原点 と X軸・Y軸・Z軸の各方向で決まるものです。(直行右手座標系です。軸2個を決めれば、残りの軸は求められます)

[Q] 暗黙的な合致コネクタとは?

合致コネクタには、暗黙的 と 明示的があります。

暗黙的合致コネクタは、合致コネクタの入力を促されるときに ソリッドの頂点や エッジの中点や 面の中心(注意:おおよその重心)にマウスを合わせた時に表示されます。

明示的合致コネクタは、PartStudio の 合致コネクタ フィーチャーで作成するものと、アセンブリで定義されるものがあります。

合致コネクタは、通常 ソリッドなどの1個の図形エンティティが所有者となっています。つまり 合致コネクタは、何かに所有されていて、単体では通常存在できません。

原点が所有する 暗黙的合致コネクタもあります。
合致コネクタ フィーチャーは、ソリッドやサーフェスを所有者として 明示的合致コネクタを作成しますが、原点を所有者にできません。

明示的合致コネクタが定義された後で、所有者のソリッドなどを 移動/回転するとき 明示的合致コネクタは、移動/回転しません。

[Q] 合致コネクタは 何に使えますか?

[A] 次のような使い方があります。

・ 位置として 原点を 使う。
例えば、押し出しで 末端の種類に(ブラインドでなく)「頂点へ」を選択した場合、頂点の入力欄の右側のをクリックすると、頂点の代わりに合致コネクタを末端位置に使えます。

・ 軸として 原点とZ軸を 使う。
例えば、回転フィーチャーで 回転軸の入力欄の右側のをクリックすると、合致コネクタを回転軸とすることができます。

・ 平面として 原点と X軸Y軸 を使う。
例えば、をクリックして スケッチ平面の代わりに 使えます

・ 完全な座標系を一致させるのに使う。
例えば、トランスフォーム フィーチャーで「合致コネクタによるトランスフォーム」で使えます。
また、アセンブリで「ファスナー合致(固定)」でも使います。

・ その他の目的で使う。
FeatureScript などでさまざまな使い方をします。

[Q] 合致コネクタのオプションとは?

合致コネクタの 原点位置や 軸の向きは、以下のオプションを使って 調整することができます。

アセンブリの合致において、オフセット、X(or Y or Z)を中心に回転 などを使って 調整ができます。

PartStudio において、フィーチャー編集で 選択した合致の右側のをクリックして 合致ダイアログを開き オプションが指定できます。
[Q] スケッチの XY軸を傾けて調整することはできますか?を参照

派生

[Q] 派生フィーチャーとは?

[A] 他の PartStudioにある図形を 挿入するフィーチャーです。

派生できるのは、

  • 同じドキュメントの別の PartStudio
  • 別のドキュメントの PartStudio
    (「ドキュメントをリンクする」共有権限が必要)
    (デフォルトで最新バージョン)

の中にある

  • パーツ(ソリッドボディ)
  • サーフェス
  • スケッチ
  • カーブ
  • 平面
  • 合致コネクタ(所有するボディが挿入されるときに一緒に挿入)

です。

同じドキュメント(のワークスペース)からの派生は、リンク元が更新されると即時に更新されます。
別ドキュメント(のバージョン)からの派生は、リンク元に新しいバージョンがあるとき、が表示されます。バージョンを変更することができます。

リンク(挿入)について詳しい説明は ドキュメント/ワークスペース/バージョン/タブの関係を参照してください。

スケッチ

[Q] スケッチ と 図面 はどう違う?

[A] スケッチは、 PartStudioタブの中で1個のフィーチャーとして作られる2次元図形で
押し出しなどのフィーチャーで使うなどいろいろな使い方ができます。

図面(Drawing) は、図面(Drawing)タブの中で作られる2次元です。
他のタブで作られた ソリッド/サーフェス/スケッチを表示し、スケール(縮尺)/用紙サイズ/図枠などを指定して レイアウト配置できます。

[Q] 平面を作成しないでスケッチを作る方法は?

[A] 平面を作成しなくても、合致コネクタからもスケッチを作成できます。

[Q] 面の輪郭(エッジ)をスケッチで使うには?

[A] 面のエッジをスケッチ要素としてコピーするには、使用(エッジ利用(投影/変換), Use) を使います。
一度に複数のエッジをスケッチ要素としてコピーする場合は、選択作成を使ってください。

他のスケッチ要素やPartなどのエッジは、Use を使わずにスケッチ拘束を付けることができます。

また、押し出しに使うスケッチで スケッチ平面のエッジは Use を使う必要がない場合があります。
 [Q] 押し出しは、閉じたスケッチから作るのですか?

[Q] スケッチの XY軸を傾けて調整することはできますか?

[A] 平面でなく 合致コネクタの上にスケッチを作ることで可能です。

「再調整」をチェックして 平面を変更することもできます。

[Q] スケッチを効率よく作る方法?

例えば、直線を描くために端点をクリックするとき、円弧にマウスを近づけると中心点が表示されて クリックできるようになります。
直線にマウスを近づけると、その線と平行の拘束が自動推測されやすくなります。

shiftキーを押しながら マウスを動かすと、自動推測はしなくなります。
自動推測でうまく作れない場合、明らかに離れた場所で図形を作ってから、後で拘束を付けることもできます。
i, e, h, v, b などのキーは拘束コマンドになります。

要素を選択すると、関連する拘束が表示されます。また、スケッチダイアログの「拘束を表示」をチェックして表示できます。
拘束のアイコンをクリックしてから、del キーで拘束を削除できます。

寸法を作成するとき、shift-q を押すと寸法選択される要素が トグルで変化します。 詳しくは 寸法

[Q] インプリントとは?

[A] スケッチ平面に選択した面の輪郭を、スケッチで使えるようにする機能です。

スケッチダイアログに、「インプリントを無効にする」というチェックがあります。 スケッチを新規作成したときは、チェックされていて、面の輪郭がシェーディング表示されています。(通常スケッチ平面に選択した面が表示されていますから、その表示をオフにするとわかります)

チェックをオフにすると、面の輪郭がシェーディング表示されなくなります。

押し出しなどで使うスケッチ領域は、スケッチ要素で囲まれた領域ですが、このチェックが入っているときは、インプリントをスケッチ要素と同じように扱い領域を作ります。

Onshape では スケッチ要素のない(空の)スケッチを作ることもできますが、このチェックがあると面の輪郭がそのまま領域となります。

スケッチ平面に、(無限)平面や 合致コネクタを選択するときは、インプリントはありません。

図面(Drawing)

[Q] 三角法にするには?

[A] 最初から第三角法の図面を用意するには、

  • 「既存のテンプレート」で 三角法 を使ってテンプレートを選ぶ。Company か 個人アカウントで用意するか、他のドキュメントから利用する
  • 「カスタムテンプレート」で 第三角法 を選ぶ。

既にある図面タブで 三角法に変更するには、

  • グラフィック画面で右クリックメニュー 「図面のプロパティ」から
  • 画面の右側中央の「図面のプロパティ」ボタンをクリックして

右側に図面のプロパティが開きますので、 ビュー の欄に「第三角法」があります。

[Q] 図面に 原点や座標軸を描くには?

[A] スケッチを作成して、ビューの [右ボタンメニュー] > [表示/非表示] > [スケッチを表示/非表示] で表示します。

[Q] 円弧/円は 描けますか?

[A] 図面タブでは、円弧/円を作るコマンドがありません。
PartStudio のスケッチ(またはエッジ)として取り込むか、インポート、他の部品からの コピーペーストすると作ることができます。

[Q] 複数部品の図面を描くには?

[A] 複数のパーツまたはサーフェスを組み合わせた状態で図面を描くことができます。

[ビューの挿入]を実行すると、次のいずれかを選択して挿入することができます。

選択する項目 挿入されるもの
Part Studio タブ内のすべて
┗ パーツ(サーフェス) 単一のパーツ(またはサーフェス)
┗ 複合部品 (Part Studio内で作成した)複合部品
┗ スケッチ 単一のスケッチ
アセンブリ (アセンブリ内で配置した状態で)タブ内のすべて

複数の部品(パーツまたはサーフェス)を挿入するときで、アセンブリを使って再配置する必要がなく、Part Studio内の全部でなく一部だけを挿入したいときは、フィーチャー「複合部品」を使うと便利です。

複数のタブにまたがる部品を挿入したいときは、アセンブリを作成します。

[Q] 図面ビューの表示要素を後から変更するには?

[A] ビューを作成した後で、表示されているパーツ、サーフェス、スケッチなどを 追加/削除する方法は次のとおりです。

パーツ または サーフェス を単体で描画している場合、それを削除したり変更はできません。(ビューを作り直します)
Part Studio 全体 または 複合部品 または アセンブリを描画している場合、それらを編集してパーツが追加/削除すると、ビューに反映されます。

親ビューがあるビューは、親ビューと同じパーツ、サーフェスが表示されます。

Part Studio 全体(または その一部)を描画している場合、同じ Part Studio のスケッチを後から追加/削除して表示ができます。

パーツ、サーフェス、スケッチの エッジ(スケッチ要素を含む)は、右ボタンメニュから表示非表示ができます。

[Q] 図面の詳細ビューの範囲を変更できない?

[A] 詳細ビューの範囲を示す円は、その中心がスナップされて拘束されると動かすことができなくなります。

詳細円は、スナップされない位置で作成し、茶色の円をドラッグして移動するようにすると、移動できます。

フォラームの投稿
MOVE A SNAPPED REF POINT OF A DETAILED DRAWING VIEW TO A FREE POINT
> This is not a “bug” - it's a current limitation
> (これは「バグ」ではありません-現在の制限です)

ABILITY TO MOVE "DETAIL VIEW" CIRCLES AFTER PLACEMENT (AFTER SNAPPING TO GEOMETRY)
> If you grab the brown circle it can be moved to another spot without snapping to geometry, it can still be moved around
> 茶色の円をドラッグすると スナップせずに別の場所に移動でき、その後も移動できます。

[Q] FeatureScript で作成したスケッチは 図面で表示できないですか?

[A] 図面で表示できるスケッチは、スケッチフィーチャーで作成したスケッチだけです。
FeatureScript でもスケッチを作成でき、で表示/非表示もできますが、図面で直接表示することはできません。

PartStudio で 別スケッチを作り、使用(Use)を使ってコピーする必要があります。

[Q] 図面で 正しく描画できない?

[A] PartStudio などの3次元と 図面のエッジの見え方が違う場合、表示レンダリングモードを変更してみてください。

正しく描画できていない ビューで 右ボタンクリックメニューから「表示レンダリングモード」を
「ベストパフォーマンス」(デフォルト)から 「最高品質」に変更してください。

ビュー > ビュープロパティ > 表示レンダリングモード
> 場合によって一部のエッジが正しく表示されない場合は、表示レンダリングモードを [最高品質] に変更する必要があります。

アセンブリ

[Q] アセンブリで、部品の編集はできますか?

[A] コンテキスト モデリングの項目を参照してください。

FeatureScript

[Q] FeatureScript とは?

[A] 3Dモデルを作成できる Onshapeによるプログラミング言語です。 新しいフィーチャーや カスタムテーブルを定義できます。 作られたフィーチャーを インポートすると Onshape の PartStudio で既存のフィーチャーと同様に使うことができます。

[Q] FeatureScript のヘルプはありますか?

画面右上の ? をクリックして FeatureScriptドキュメント(英語)を見ることができます。

[Q] 利用できる FeatureScript はありますか?

[A] 以下の FeatureScript が利用できます。

これらの FeatureScript は、リンク またはコピーして利用可能です。(著作権による制限の記載がなければ)

フィーチャースクリプトを利用するためには、「カスタムフィーチャーを追加」を行います。

以下も参照してください。
[Q] フィルパターンや スケッチパターン はありますか?
Githubにある FSリンク集

[Q] FeatureScript は安全ですか?

[A] FeatureScript で作られるフィーチャーは、すでに作られている別のフィーチャーや 挿入された PartStudioタブ以外のタブに影響しないように作られています。
もちろん他のドキュメントに影響することはありません。
FeatureScript は安全に動作するよう設計されています。

[Q] FeatureScript は アセンブリや 図面(Drawing) で使えますか?

[A] 使えません。FeatureScript(FS) は PartStudio だけで動作します。
FSフィーチャーを PartStudioに挿入し、その PartStudio や Part を アセンブリや 図面で使うことはできます。

よくある質問_faq.txt · 最終更新: 2022/10/20 05:56 by oda

ページ用ツール